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Overview 
 

The Citibank® Customized Reporting System (CCRS) replaces the current Ad Hoc Reporting 
Tool with a best-in-class business intelligence engine that supports your need for consolidated 
regional and card level information.  CCRS utilizes a web-based interface to access our 
Commercial Card Global Data Repository so that critical business information is at your ready in 
the formats that you require.  

CCRS is easy to use and you can begin creating and running reports after only a short lesson.  
Knowledge of databases and data relationships is helpful, but not necessary to create and run 
most reports.  The user interface will guide you in selecting the information that you want.   

A few of the features that you will be able to take advantage of are listed below: 
• Predefined Shared Reports 

Our selection of shared reports was specifically created to save you time and 
effort for the most requested types of reports.  A simple click and the report will 
run and present you with the information that you need. 

• Scheduled Reports 
If you like a report that you have created and want to have it run on a periodic 
basis, CCRS allows you to subscribe to the report.  No more remembering to run 
reports, they will be waiting for you after CCRS automatically creates them for 
you.   

• Data Download and Presentation Formats 
CCRS supports a wide variety of formats to save your data on your PC, including, 
Excel, CSV, HTML, Excel with formatting and Plain Text.  In addition, you can 
download charts right into Excel and download in PDF files. 

• Built-in Summary Capability 
Do you want to see data on a summary level?  CCRS automatically summarizes 
your data so that you see only the data that you want without having to wade 
through all the detailed information.   

• Built-in Drill Down Capability 
Do you want to see specifics about an individual item?  You can drill down to get 
related information on that line item even if you have not selected that 
information to be included in your report.  

 
This User Manual gives you general information and step-by-step instructions on the 
basics of using CCRS.  Throughout this user manual you will see tips to help you better 
utilize CCRS.  As you begin using the tool, you will find CCRS is easy to use, with the 
flexibility to meet your ad hoc reporting needs.   
 
 
 
 

 



System Requirements  
 

You do not need any proprietary Citibank® hardware or software to be installed for you to use 
CCRS.  Basically, if you can connect to the Internet, you can use CCRS.  The following is the 
minimum hardware and software needed and a preferred configuration that will give you 
optimal performance.   

Hardware 
• IBM compatible Pentium class computer, 133 Mz, with 64 MB RAM, 250MB hard 

disk free space 
• Macintosh Computer (I-Mac or above) 

Software 
Required Software 

• Windows® 95 or higher 
• Microsoft® Internet Explorer 5.5 with service-pack 1; OR Netscape 4.73 or higher 

(but not Netscape 6.0). 
 

Additional Software to Download and Present Your Data 

The following list of software, while not necessary, will allow you to save your data on your PC 
and present your reports in various formats 

• Acrobat®  Reader, version 4 or higher 
• Word processing software, such as Microsoft® Word 
• Text reader, spreadsheet or database software capable of reading/importing text 

files. 

Preferred Hardware, Software and Communications 
Configuration 

The following preferred hardware and software configuration will optimize your experience: 
• 500 MHz or higher processor, 256mb RAM or higher, 2GB hard disk free space 
• High speed internet connection 
• Preferred browsers include Internet Explorer 6 and Internet Explorer 5.5 with 

service pack 1. 
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CCRS Reporting Fundamentals 
 

As you begin to create and run reports, you will need to have a basic understanding of CCRS.  
The following section gives a common understanding of terms used and familiarizes you with 
common definitions for reporting and data fundamentals.  Some of the terms previously used in 
the old ad hoc reporting tool have new names.  

The Global Data Repository 

Citibank created the Global Data Repository (GDR) to store all commercial credit card 
information for CCRS. It is also referred to as a data warehouse.  Every time an account is 
created, changed or deleted, information about that account is captured.  Also, every time a 
financial transaction against the card is processed (purchases, payments, cash advances, credits 
for returned goods, etc), this creates additional information.       

There are two basic types of information or data that are captured and stored in the Global Data 
Repository (GDR): 
 

• Account information 
• Transaction information 

Global Data Repository
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Data
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Travel itinerary
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Transaction
Data

Global Data Repository

 

 

As you can see from the diagram, the GDR receives information from a variety of sources.  The 
GDR arranges the information into a logical structure that groups Account data together and 
Transaction data together and defines the relationship between the two types of information.  
CCRS enables you to easily access this information so that you can create reports and download 
data. 
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User Objects 

User objects are those items you can use in your report.  In most cases they will be attributes, 
metrics, filters and prompts.   These objects are described below.   

Attributes 

Attributes can best be described as related properties of Account or Transaction information, 
identifying or describing an account or a transaction in some way.  Examples of account 
attributes include Account Name, Account Number, Card Limit and Social Security Number.   
Examples of transaction attributes include Transaction Amount, Transaction Post Date or 
Merchant Name.    You use attributes to analyze account information, transaction information 
or a combination of both.     

• Attribute elements are actual data values that are displayed on reports. For 
example, the attribute Merchant City might have attribute elements such as 
Dearborn, Irving, Las Vegas, Louisville, etc. These values are stored in the GDR.    

 Translation Tip:  
In ad hoc an attribute was an element. The information that appeared when an element was 
selected was called a value. Now, an element is an attribute, and the information is an attribute 
element. 
Element = Attribute 
Value = Attribute Element 

Metrics 

A metric is used when you want to measure or summarize data.  Often it is a 
summarized value of an attribute.   As an example, 

• Count of Cards is a metric that totals the number of cards 

• Transaction Amount Total is a metric that totals all transaction amounts 

 Concept  Tip:  
A metric works the same way a scale works.  Instead of ounces or pounds, it measures in 
Number of Cards or Transaction Dollars. In other words, if you put the Hierarchy 1 container 
(attribute) on the Number of Cards (metric) scale, it will give you how many cards are in 
Hierarchy 1.  Put the Merchant container on the Total Transaction Amount scale and it will 
automatically total in dollars all the transaction amounts in the Merchant Container.  You can 
therefore put any “container” on the right type of scale to automatically total how many or how 
much. 

 7



 

In th
metr
for ea

 

 
 

Field
repo
nece
repo

Filt
A filt
resul
type 

For e
howe
Nam
type,
“cont

Pro

A pr
deter
you w

In th
secon

 8
e example below the Total Transaction Amount has been defined in the CCRS as a 
ic.  When a metric is included on a report, it automatically totals all transactions amounts 
ch Merchant Name. 

Translation Tip:  
s that used to be used as summary fields are now already defined that way. As a result, 
rts can be created with summary totals, and a separate SUMMARY command is no longer 
ssary. The field Transaction Amount will also be defined as an attribute to allow detail 
rting. 

ers 
er specifies the conditions that the data must meet in order to be included in the report 
ts. Filters provide you with the ability to hone in on specific information, by limiting what 
of data is returned from the database.  

xample you may want to analyze Total Transaction Amount by day for Merchant Names; 
ver not all merchants, only certain merchants. You would create a filter on the Merchant 
e attribute to include only the merchants that you want.  You can create the filter by certain 
 name, or other combination.  You can choose from a lengthy list of criteria, such as 
ains” or “like”.  

mpts 

ompt is an open-ended question that you can have some input into. Prompts allow you to 
mine at the time a report is run,  which  attribute elements (values), metrics, filters, etc. 
ant in a report.     

e example below there are two prompts: first, one to allow the selection of a date range; and 
d, a prompt that asks you to select from a list of Airline Carrier Codes to be included.   

 



 

 

Templates 

A template is the layout or format for a report in CCRS.  Templates specify what information is 
to be retrieved from the data warehouse and how the results should be displayed. A template can 
be saved and reused in as many future reports as the user wishes.  Typically, templates consist of 
a combination of attributes and metrics.   

In the example below the template has the attributes Merchant Cty, Merchant St, Merch 
Cntry and Merchant Zip; and the metrics Number of Room Nights and Trans Amt   
Although the attributes and metrics both appear on the same line, one can see where attributes 
end and metrics begin by the “metrics” column. Items to the right of that column are, in fact, 
metrics. 
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Reports & Documents 

The following diagram demonstrates how reports and documents are created using the 
fundamentals that have been described above.   
  

 
Figure 0-2: structure of system relationships 

 

Output 

There are three major types of output from the reporting system: 

• Reports 

• Documents 

• Graphs 

• Downloaded Data  
Reports 

A report is defined as the combination of a template (the layout) and a filter (the criteria).   The 
following is a sample report that contains the attributes Trans Date and Airline Carrier 
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Code, the metrics Total Air Legs and Total Fare Amount and a filter for Airline Carrier 
Code = BA, UA, or US. 

 
 

Documents 

A second type of output available is a document. A document is a container for formatting, 
displaying and distributing multiple reports.  It can contain any of the following: text, images, 
tables, hyperlinks, and one or more reports. A document is often used for displaying reports of 
related subject matter; for example, three reports about monthly inventory. 
 
Graphs 

A third type of output is graphs.  Many types of graphs are available to put your data into a 
picture that can simplify your presentation. 
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User Set-up and Maintenance 
 

User IDs should be requested through your Program Administrator.  After Citibank receives 
your request, then it generally takes two to three business days before you can access CCRS 

Your Program Administrator will handle maintenance requests also.  These generally include 
changes in your name, email address or the data that you are entitled to see.   Maintenance 
requests also take two to three business days to complete.  

Access to CCRS and Logging in 
 

CitiDirect Users 

CCRS will initially be accessed using a separate web site http://datatrax.trx.com .  The website 
address can be obtained from your Program Administrator.  

CCRS will be accessed directly from the CitiDirect option for Ad Hoc Reporting at a later date.  
You will be directed to the reporting site and presented with the CCRS Sign-on Screen.  You 
must enter your separate CCRS User ID and password until Single Sign-on through CitiDirect is 
available.   
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Enter your User ID and Password here. 

After Single Sign On is available, you will no longer be required to remember a separate 
password.  You will be signed in automatically upon selecting the option for Ad Hoc Reporting.  
 

Direct Users of CCRS 

Initially, you can access CCRS by using the web site: http://datatrax.trx.com .   However, the site 
is scheduled to move to an umbrella web page known as CitiManger.   

Users who do not use CitiDirect can access CCRS directly through CitiManager 
(http://www.citimanager.com).  CCRS will appear as an option under and direct you to the 
CCRS Log-in Screen.   CCRS uses Standard authentication, so once you have logged selected the 
link, you are prompted for a separate login for access.  
 

Initial Password Change  

If this is the first time that you have logged in, you will be asked to change your password.  
Passwords should: 
 
be at least 6 characters long 
contain both upper case and lower case characters 
not contain more than two consecutive characters 
not include leading or trailing spaces 
not be the same as your user name 
not contain the following characters: > < ' " = ; % ^ \ | 

You may not change your password more than once per day. 

If you enter an incorrect User ID or password, the system will display the following message: 
 
 
 
 
 

 
 

Error in login 
 
 
The password supplied is incorrect or the user name and password you provided do not access any of the projects 
currently available to the system. 

You will be presented with the Secure Log-In Screen again where you may enter your User ID 
and password again.   

If you do not remember your User ID or password, please call the Help Desk to retrieve your 
User ID and/or reset your password. 

 13

http://datatrax.trx.com/
http://www.citimanager.com/


 

Home Page and Navigating Primary Menus  
 

Once you have signed in, you will be presented with your Home page.  The Home Page as will as 
all the main pages contain the Primary Menu.  When you select a Primary Menu option, you will 
quickly be able to navigate to the main pages of CCRS.   

Summary of Primary Menu Options 

From your Home Page, you can traverse to any area of CCRS.  The following table describes the 
purpose of each part of CCRS.  

 

 Home  
 This is the first page that you will see after you sign in.  The 

Home Page gives you a Summary of the reports that you 
may access directly.   

Shared 
Reports 

 

 

The Shared Reports Page contains predefined reports that 
are shared with other users.  These are standard reports 
that were created by Citibank or by those authorized by 
your Program Administrator.   

My Reports 

 

This is the default location for saving reports that you 
create.  This folder contains reports that only you can see 
or access.   

Create 
Reports 

 

This provides you with options for creating a new report.  
If you want to do some type of analysis that is not already 
provided by a standard report, you can create your own 
report. 

My 
Subscriptions 

 

This shows the reports you have scheduled to run on a 
periodic basis.  You can change or delete scheduled reports 
from this page.  The actual reports are run automatically 
and added to your history list.   

 
History List  

This displays messages about the reports you have run as 
well as the reports to which you have subscribed.  When 
creating reports, you may add them to your History List so 
that you do not have to wait for them to finish.  They will 
then appear here with a status.  

 14



Preferences 
 

This enables you to change preferences for a variety of 
settings to customize how you want CCRS to work for you. 

Running Shared Reports and My Reports 
 

Shared Reports 
Reports that are saved by others for your use will appear in the Shared Folder Reports.  Global 
Shared are standard reports that have been created by Citibank.  Your Organization’s Shared 
Report Folder will contain reports that have been placed there by your Program Administrator. 

My Reports 
Reports that you create can be saved in My Reports.  These are reports that you created or 
modified from the Shared Report Folder and can be accessed only by you.    
 
. 
 

Running a Report 

In the Shared Reports folder, there are numerous predefined reports that you can run for many 
of your reporting needs.  You will see various sub-folders and reports.  
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The report will begin to run immediately, unless the
that you must answer before the report runs.  

 

 

 
 
 

The Wait Page will appear and display the status of y
changes as the report is processed.   You have three m

• Check Status Again immedia

• Add to My History List adds to 
wait for y

• Cancel the Report cancels t
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To run a shared report:    

1. Click Shared Reports.  
Subfolders exist for each 
category of reports. 

2. Click the folder you want to 
open. 

3. Click the report you want to 
run. 
re are prompts associated with the report 

our report request.  The status periodically 
ain options: 

tely checks the status of your report 

your History List when you don’t want to 
our report to complete 

he report  

 



When your report has completed processing, it will appear on the screen. 

Reports Toolbar 

This report page contains both a report toolbar and menu bar that is used to access a variety of 
functionality.    The report page also has four menus:  Report, View, Data, and Format.  These 
menu options contain these functions as well as other functions that are covered later in this 
manual.   The following table defines each of the report toolbar icons. 

 

Toolbar 
Description 

Icon Tool Description 
Alternate Method 

Design Mode 
 

Displays the report in 
Design Mode, which 
enables you to modify the 
report. 

You can also access this 
setting by clicking Design 
Mode on the View menu. 

Grid 
 

Displays the report in 
column and row format. 

You can also access this 
setting by clicking Grid on 
the View menu. 

Graph 
 

Displays the report in graph 
mode. 

 

You can also access this 
setting by clicking Graph 
on the View menu. 

Grid and 
Graph  

Displays the report in grid 
and graph mode at the same 
time. 

You can also access this 
setting by clicking Grid 
and Graph on the View 
menu. 

Print 
 

Enables you to format and 
print the report. 

You can also access this 
setting by clicking Print on 
the Report menu 

Export 
 

Enables you to export the 
report to another application 
or to a format that can be used 
by another application.  You 
can export to Excel, HTML file, 
plain text file, or CSV file. 

You can also access this 
setting by clicking Export 
on the Report menu 

PDF 
 

Enables you to export the 
report to a PDF file. 

You can also access this 
setting by clicking PDF on 
the Report menu 
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Toolbar 
Description 

Icon Tool Description 
Alternate Method 

the Report menu 

Reprompt 
 

Only appears for reports 
that contain prompts.  
Enables you to be re-
prompted and make new 
selections for the report. 

You can also access this 
setting by clicking 
Reprompt  on the Data 
menu 

Refresh Data 
 

Enables you to re-execute 
the report. 

You can also access this 
setting by clicking Refresh 
on the Data menu.   

Save 
 

Enables you to save the 
report. 

You can also access this 
setting by clicking Export 
on the Report menu 
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Creating Reports using Dynamic Report Builder 

CCRS contains some standard reports that you can use to perform analysis, but you can also 
create your own reports.  By clicking on Create Report from the Primary Menu selections, you 
will be brought to the Create Report page.     

There are two ways to create reports in CCRS: 

• Dynamic Report Builder 

• Common Attribute Reports 

Dynamic Report builder is the most flexible and robust method for creating reports.  You will 
have access to all attributes and be prompted for metrics and filtering criteria.  

If you need a report using only the most commonly used Account or Transaction attributes, then 
you should use either the Account Common Attributes Report or the Transaction Common 
Attributes Report.    

Creating a Dynamic Report 

Choosing the Dynamic Report option will bring up a screen with a series of windows that allows 
you to select attributes and metrics and also prompts you for Account Type and Transaction 
Post Date range.  

 
 
Attribute Windows 

Attributes are organized in windows that logically group attributes that you can select to build 
your reports.  These attribute windows are: 

• Hierarchy 
• Account 
• Transaction 
• Line Item Detail  
• Airline Detail 
• Hotel Detail 
• Reallocation 
 

As more data is loaded into the Global Data Repository, you may see additional windows and/or 
additional attributes within each window. 
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As you can see, the windows are organized from the broadest attributes down to the most 
detailed attributes.  In other words, Hierarchy being the broadest attribute and Reallocation, 
Line Item Detail, Airline Detail and Hotel Detail being the most detailed attributes.  

You can select values by highlighting them in the Available: window and using the arrow 
pointing to the right to add them to the Selected: window as shown below: 

 

To remove a value, you can select the value in the Selected: window and use the arrow pointing 
left to move it back to the Available:  window.  

 Time Saving Tip:  
Instead of highlighting attributes in the window one at a time, you can highlight multiple 
attributes by utilizing the Shift or Ctrl keys.    
 
Metric Prompts 

Next you will see metric prompts.  These are summary data associated with Account, 
Transaction and Detail Transaction Attributes.  These are selected in the same manner as the 
attributes above. 
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Account Type and Transaction Date Range Prompts 

Finally you can select attribute elements (values) for two filter prompts that are used in almost 
all reports: 

• Account Type to limit the type of account you want to analyze 
when Account attributes are chosen 

• Transaction Post Date Range to limit the posting date range when Transaction or 
Transaction Detail attributes are chosen.  

Below is an example of the Account Type Prompt. 
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Choosing to Edit, Save or Cancel a Dynamic Report 

Now that you have answered the prompts, you are ready to edit, save or cancel your report.   

  

Edit in Design Mode will allow you to refine or modify your report by bringing you to 
Design Mode.  Your report is not saved, but you may also save and cancel your report 
from Design mode as well. 

Saving will allow you to save your prompted selections without running the report.    

Canceling will wipe away all your selections and return you to the Create Report Menu 

Editing a Report Template in Design Mode 
 
Design Mode allows you to modify how your report will look as well as filter data in or out of your 
report.   It is especially useful when making several changes as you can make these changes all 
at once and then execute the report.  

In Design Mode there are two object panels—All Objects and Report Objects  as well as a 
Template.  All Objects contains all the objects in the data warehouse.  Report Objects displays 
all the objects contained in the current report. The template displays a representation of how 
your report will look before it is run.  

The report opens in Design Mode: 
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Adding attributes and Metrics Report Objects Panel 
 

1. In the Report Objects panel, left -click on the object you want to add. 
NOTE:  You can also drag and drop the object onto the template. 
 

 
 
 

Removing attributes and Metrics Report Objects Panel 
 

1. Click the X button under the object you want to remove. 

 
NOTE:  You can also drag and drop the object into the Report Objects panel, or you can 
right-click the object and click Remove from Grid. 
 

 
 
Repositioning Attributes in Design Mode 
Attributes and metrics can be repositioned using the right or left arrow buttons under the 
attribute name in the grid.  However, you can also drag and drop the attributes to the left or 
right.    
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How to Create a Report Filter 

1 In Design Mode for the report, make sure the Report Objects tab in the far left window is 
selected as shown below: 

 

2 Click on the Edit Report Filter button as shown below: 

 

3 In the Report Objects window are all of the attributes and metrics you will need to 
create any filter that you wish for a report.  Left click on each attribute you wish to add to 
the filter and drag and drop them into the Report Filter window.   

 

4 You will then have the opportunity to choose the criteria under which you would like to 
filter. 
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5 Continue the process for all other attributes that you need to add to the filter. 

6 You can also add the metrics to the filter.  To add any metric to the Report Filter window, 
left click on it in the Report Objects window, drag and drop it to the right hand Report 
Filter window.  You will notice that you get different inequality criteria options when 
creating a metric filter.  You did not see these inequalities when creating an attribute 
filter. 

7 When finished creating the report filter click on the Execute Report button in the 
upper left hand corner as shown below: 

 

 

Saving a Dynamic Report 

Saving your Dynamic Report will ensure that the selections you made are saved.  You do not 
have to run the report in order to save it.     

1 Click on the Save button and the Save Report page will be displayed as below.  It will be 
defaulted to save in My Reports.   

 

2 In the Save report as box, type the name for the report as shown below: 
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3 Because you are saving a prompted report there are several choices listed under the Save 
report as window with checkboxes in front of each option.  The options are described in 
the table below: 

 
The following table explains the save options for prompted reports.   

Save the report as a static definition. 

If you select this option, the report is saved 
without any prompts.  If you run the 
report, you are not re-prompted; instead 
the report uses the answers you provided 
when you first created the report. 

Save the report with the prompts 
embedded in the filter. 

If you select this option, the report retains any 
prompts that enable you to select filter criteria, 
but any prompts that enable you to change the 
template are not saved.  If you run the report, 
you are only re-prompted to select filter 
criteria.  Your filter selections from the last 
time you ran the report appear as the default 
values.  The report uses the template criteria 
you selected when you first ran the report. 

Save report with the all the embedded 
prompts. 

If you select this option, the report retains 
all the original prompts.  If you run the 
report, you are re-prompted on all the 
original prompts.  Your selections from the 
last time you ran the report appear as the 
default values. 

4 You may also further elaborate with a description of your report in the Description 
window.   

 Report Saving Tip:  
Because you are saving a report template, be careful that your report is named in a general way  
As an example, if you run a monthly report of Merchant Transactions, naming the report 
“Merchant Transactions from 10-01-03 to 10-31-03” will not be appropriate when you run the 
report the next month.  A better name might be Monthly Merchant Transactions.    
 

5 Click the Save button.  

Your report will be saved in My Reports 
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Creating a Report Using Common Attribute Reports 
 
You can create reports another way using the Common Attribute Report Templates.  Using the 
Common Attribute Reports to create a report is similar to using the Dynamic Report builder.  
However, Common Attribute reports make available only a limited set of attributes.  It is not as 
flexible or robust as the Dynamic Report builder.  The disadvantage is you can choose from only 
a limited number of attributes; the advantage is that it is faster to see the results of changes in 
your report.   
  
There are two types of Common Attribute Reports: 
 

• Account Common Attribute Reports 
Contain only Hierarchy and Account information, no transaction or detail 
information is available. 

• Transaction Common Attribute Reports 
Contains only Hierarchy, limited account information and limited transaction 
information.  No detail transaction information is available. 

 

 
 

 
 
To create an Account-related report 

1. Choose Account View 
2. Click on next 

 
You will be shown an account type prompt screen 
 

 
 

3. Select a value for account type.  Selecting no value will select ALL types. 
4. Click on the button “Edit in Design Mode” 
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You will see the Object browser to the left with the most commonly used account attributes.   
This screen is the same as the screen described in the section entitled “Editing a Report 
Template in Design Mode” covered earlier in this manual.  
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Viewing and Modifying an Executed Report 
 
Once you have run your report and it appears on the screen, you will be able to modify your 
report further.   In most cases, these modifications will occur on the screen without having to run 
your report again to see the results.   

Using the Object Browser to Modify a Report 

You can also use the Object Browser to make changes to your report.  When you use the Object 
Browser, the report automatically re-executes after every change you make, so you should only 
use the Object Browser if you are making minor changes.  If you are making multiple changes, 
use Design Mode as you can make all your changes before re-executing the report. 

     

 

       

 

To access the Object Browser from a 
report: 
 

1. On the View menu, click 
Object Browser. 
OR 
On the Data menu, click Add 
Report Objects. 

 
 

You add or remove objects using the 
Object Browser exactly as you do in 
Design Mode.  You will see the 
change right on the report.  However, 
if the change requires the system to 
go back to the database, you will 
receive a text box indicating that the 
system is processing.     
 
When you are finished making 
changes, you can close the Object 
Browser by clicking the X button in 
the right-hand corner of the Object 
Browser. 

 

The Object Browser opens to the left of the report. 
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Viewing and Modifying a Report Filter 

You can view the report filter while in Grid, Graph, or Design mode, but you can only modify it in 
Design Mode.  A Report Filter pane opens at the top of the report to display the report filter. 

 

 

 

 

To view the report filter from Grid 
or Graph mode: 
 

1. On the View menu, click 
Report Filter.   

 
To modify the report filter: 
 

1. Open the report in Design 
Mode. 

2. Click Edit Report Filter. 

3. Make your changes. 
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Creating a View Filter 

The report filter contains the conditions or criteria that restrict what data is returned from the 
warehouse when you run the report.  However, in addition to the report filter, a report can also 
have a view filter.  View filters are conditions or criteria that are applied to the result set after the 
data has been returned from the warehouse.  All the data contained in the report filter is brought 
back from the warehouse, but only the data in the view filter is displayed.   

You can see view filters while in Grid, Graph, or Design mode, but you can only create or modify 
them in Grid or Graph mode. 
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To view, modify, or create a view filter 
on a report from Grid or Graph mode: 
 

1. On the View menu, click 
View Filter. 

 

A View Filter pane opens to display the 
view filter 
 
To create a view filter: 
 

1. In the View Filter pane, click 
the Add Condition link. 

2. In the Filter On box, select the 
object on which you want to 
filter. 

NOTE:  You can filter on any 
object contained in the Report 
Objects panel. 
3. Click Continue. 

4. Select how you want to qualify 
on the object. 

5. Click the apply button.  The 
report changes to display only 
the data contained in the view 
filter. 

 
 To modify an existing view filter: 
 

1. In the View Filter pane, click 
the condition you want to 
modify. 

2. Make your changes. 

3. Click the apply button.  
 



Inserting a New Metric 

You can also modify a report by creating new metrics from existing metrics already in the report.  
When you save the report, they are saved as part of the report.  

 
To insert a new metric: 

On the Data menu, click Insert New Metric.  

 

 

 
 
In the Rename/Edit Objects pane, in the Name box, type the name of the new metric. 

In the Definition box, drag and drop the objects you want to use to create the new metric 
from the template.  
NOTE:  You can also type mathematical operators and constants in the Definition box. 

 
 
Click OK. 

 

 33



Renaming an Object in a Report 

You can rename objects in a report.  When you rename an object, the name is only changed on 
the report itself.   
 
To rename an object in a report: 
 

1. On the Data menu, click Rename/Edit Objects or right click on the header to be 
renamed as shown below: 

NOTE:  Editing objects refer to inserting new metrics.  You cannot edit the definition of an 
existing metric.   

 

 
2. In the Rename/Edit Objects pane, in the first dropdown box, select the object in the 

report that you want to rename.   This will already be selected if you used the right click 
method in Step 1 above. 

3. In the Name box, type the name you want to appear in the report. 
4. Click OK. 
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Paging by an Object on a Report 

When you have a report with a large result set, you can more easily view the information for the 
report by paging the data.  To do this, you can page by any object on a report.   All of the data for 
the report is still retrieved at one time from the database; you are simply retrieving it to view in 
segments. 

 

 

 

To page by an object on a report: 
 

1. Right-click the object you want 
to page by, point to Move, and 
click To Page Axis. 

NOTE:  You can also drag and 
drop an object into the Page By 
To select an element to page by: 
 

1. In the Page By pane, in the 
dropdown box, select the 
element you want to view. 
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Pivoting Data on a Report 

You can also change the placement of data on a report.  You can move objects between the row 
header, column header, and page by field.   You can also change the relative order of display for 
data in the rows, columns, or page-by field. 

To pivot data, you can drag and drop objects onto other areas of the report, right-click an object 
and use the Move menu, or use the pivot buttons. 

 

 

 

 

 

The report display changes to reflect the new arrangement of th
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To access the pivot buttons: 
 
1. On the View menu, 

click Show Pivot 
buttons. 
 

 

To pivot an object on a report: 
 

1. Under the object you want to 
move, click the appropriate 
pivot button. 

NOTE:  You can also pivot data 
by dragging and dropping the 
object onto a different area of the 
report or by right-clicking the 
object, pointing to Move, and 
clicking the area of the report to 
which you want to move the 
object. 

 
1 On the View menu, click 

Show Pivot buttons. 
 

e data. 



 
 

Sorting Data on a Report 

Sorting is defaulted to ascending alphabetic and numeric standard.  However, you can set up 
your own sort order for the data on a report.  You can sort by up to three fields in succession in 
ascending or descending order. 
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The report display changes to show the new sort orde

 

Adding Totals to a Report 

You can add various types of subtotals and grand tota
on it, you can also choose to hide the totals or to remo
 
To add grand totals to a report: 
 

1. On the Data menu, point to Totals, point to 
Grand Totals Only. 
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To sort data on a report: 
 

1. On the Data menu, click 
Sort. 

2. In the Sort pane, in each 
dropdown box, select the 
criterion by which you 
want to sort. 

3. For each criterion, select 
Ascending or 
Descending order. 

4. Click OK. 
 

r. 

ls to a report.   If a report already has totals 
ve them. 

the type of total you want to add, and click 



 
 
 
 
To add a grand total and subtotals to a report: 
 

1. On the Data menu, point to Totals, point to the type of total you want to add, and click 
All Subtotals. 
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To remove totals from a report: 
 

1. On the Data menu, point to Totals, point to the type of total you to want to remove, and 
click none. 

 
 
To hide totals on a report: 
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1. On the Data menu, point to Totals, and click Show Totals.  To show the totals again, 
repeat this step.  This option shows and hides totals on a report. 
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Filtering on Selections in a Report 

You can also narrow down the amount of data you are viewing by filtering on selected elements 
of the report.  This would be useful when you want to display selected data that is not easily 
filtered or is random in nature.   

 
 

 
 
The report display changes to show only the eleme
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To filter on selections in a report: 
 

1. On the Data menu, click Filter 
on Selections. 

2. Click the checkbox beside the 
elements you want to view. 

3. Click OK. 
 
 
 

 
 

 

nts on which you selected to filter. 



Printing a Report 

You can print reports.  When you print reports, you have the option to change a variety of print 
settings, including adding custom headers and footers, fitting a report to a page, and changing 
paper size and margins.  

 

 

 

When you choose to print a report, a new we

 

To print a report: 
 

1. On the report toolbar, click the 
print icon. 

NOTE:  You can also print a report 
by clicking Print on the Report 
menu. 
2. Change the print settings as 

desired. 

NOTE:  You can access advanced 
print settings by clicking Show 
advanced options. 

3. Click Show Printable 
b page opens so you can change print settings. 
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In addition to changing standard print settings, you can create custom headers and footers.  The 
icons in the Header/Footer Editor enable you to easily insert report information such as the 
report name, filter, template, filter details, project, user, date and time. 
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To create custom headers and footers: 
 

1. On the print options page, 
under Header and Footer, 
select Use custom settings. 

2. Click the (edit) link. 

3. In the Header/Footer 
Editor, customize the header 
and footer as desired. 

4. Click Apply. 
 

 



Exporting a Report 

You can also export reports to other formats.  You can export grid reports to Excel, PDF, CSV 
(file format that can be imported into Excel), plain text file, or HTML file.   You can export graph 
reports to Excel or HTML.  

 

 

 

When you choose to export a report, a new Web pag

When you export the report, a document of the file t
exported to that document. 

 

To export a report to Excel, CSV, plain 
text, or HTML format: 
 

1. On the report toolbar, click the 
export icon. 

NOTE:  You can also perform these
types of exports by clicking Export 
on the Report menu. 
2. Change the export settings as 

desired. 
NOTE:  You can export the entire 
report or just the portion you are 
viewing. 
e opens so you can change export settings. 

 

ype you selected opens, and the report is 
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To export a report to PDF format: 
 

1. On the report toolbar, click the 
export to PDF icon. 

NOTE:  You can also perform a 
PDF export by clicking PDF on the 
Report menu. 
2. Change the export settings as 

desired. 
NOTE:  You can customize the 
header and footer by clicking the 
(edit) link beside Header and 
Footer. 



When you choose to export a report to PDF, a Web page opens so you can change export 
settings. 

 

 

When you export the report, a PDF document opens, and the report is exported to that 
document. 

 

 

 

Subscribing to a Report 

In addition to running reports manually, you can subscribe to a report so that it runs 
automatically based on a schedule.  The results are saved and a message is delivered to your 
history list where you can retrieve the report results.   
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You can view subscriptions you create under My Subscript
subscriptions and view them from this page. 
 
To view your subscriptions: 
 

1. On the top of any page in the project or on the project h
Subscriptions. 

 

 
To modify a subscription: 
 

1. On the My Subscriptions page, click the Edit link be
modify. 

2. Change the schedule you are using for the report. 
3. Click OK. 
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To subscribe to a report: 
 

1. On the Report menu, click 
Subscribe. 

NOTE:  If you have made 
changes to a report, you must 
save it before you can subscribe
to the report. 
2. In the Subscriptions 

pane, in the Choose a 
schedule box, select the 
schedule you want to use. 

3. Click OK. 
 
 

 

 
 

ions.  You can also modify your 

ome page, click My 

 

side the subscription you want to 



 
 
To unsubscribe to a report: 
 

1. On the My Subscriptions page, select the checkbox for the report to which you no 
longer want to subscribe.  

2. Click Unsubscribe. 
3. Click OK. 

 

 
 

Drilling on a Report 

Whenever you run a report, you can also drill on the report.  Drilling enables you to view data at 
levels other than those originally displayed on a report.  You can drill up to higher-level related 
attributes or down to lower-level related attributes.    You can drill on part of a report or all of a 
report. 

You can drill in one of five ways: 

• Clicking an element hyperlink (automatically drills down to the immediate child just for 
the element you selected) 

• Clicking a header hyperlink (automatically drills down to the immediate child for all 
elements of that attribute) 

• Right-clicking an element (enables you to choose a level within the same dimension to 
which you want to drill just for the element you selected) 

• Right-clicking a header (enables you to choose a level within the same dimension to 
which you want to drill for all elements of that attribute) 

• Using the Drill pane (enables you to choose the attribute or attributes on which you want 
to drill and the level to which you want to drill; also enables you to drill on multiple 
attributes at one time and to drill on all or part of a report using the drill checkboxes) 

 
To drill down to the immediate child for a specific element: 
 

1. Click the element on which you want to drill. 
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To drill down to the immediate child for all elements of a specific attribute: 
 

1. Click the header for the attribute on which you want to drill. 
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When you drill on a report, the report you drilled to is

 

 
To drill up or down within the same 
hierarchy for a specific element: 
 

1. Right-click the element on 
which you want to drill, point to 
Drill, and click the level to 
which you want to drill. 

 
To drill up or down within the same 
hierarchy for all the elements of a 
specific attribute: 
 

1. Right-click the header for the 
attribute on which you want to 
drill, point to Drill, and click 
the level to which you want to 
drill. 

OR 
On the Data menu, click Drill. 

2. In the Drill pane, in the 
dropdown box beside the 
attribute on which you want to 
drill, select the level to which 
you want to drill. 

NOTE:  Having the Keep parent 
while drilling setting selected 
means that the attribute you are 
drilling from appears on the 
resulting report as well as the 
attribute to which you are drilling. 
3. Click the apply button. 
NOTE:  You can also use this 
option to drill to selected elements 
of the attribute.  To drill on only 
part of the report, click the 
checkboxes beside the elements you
want to drill on before clicking the 
apply button. 
 

 displayed on the page. 
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Formatting a Grid Report 

When you run a shared report or a report that you have created, reports have a default format.  
However, you can also customize the format of reports yourself.  You can format reports down to 
the individual cell level. 

 

 

 

 

 

 

 

 

 

To format a report in Grid mode: 
 

1 On the Format menu, click 
Advanced Formatting. 

NOTE:   This action displays the 
Format pane.  You can also 
display this pane by right-
clicking an object in the report 
that you want to format and 
clicking Advanced 
Formatting. 
 
OR 
 
On the Format menu, click 
Toolbar. 
 
OR 
 
On the View menu, point to 
Toolbars and click Format. 
NOTE:  These actions display 
the formatting toolbar, which 
you can also use to format 
reports. 
 
1 On the Format pane or 

toolbar, format the report as 
desired.  

2 If you are using the Format 
pane, click Apply after each 
formatting change. 

NOTE:  You can format the row 
or column axis headers and 
values, or you can choose to 
format individual attribute or 
metric fields.  You can change 
the font, font size, colors, 
number type, alignment, and a 
variety of other settings. 

3 If you are using the Format 
pane, when you have finished
all your changes, click OK. 
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The report display is updated as you apply each formatting change. 

 

Changing the Autostyle of a Report 

In addition to formatting the report on your own, you can also change the format of the report 
by selecting other predefined autostyles.  Web comes with a variety of autostyles that you can 
use. 
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To change the autostyle of a report: 
 

1. On the View menu, point to 
Toolbars and click Report. 

NOTE:   This action displays the 
Report toolbar, which enables you 
to change the autostyle of a report.   
2. On the Report toolbar, in the 

Autostyle box, select the 
autostyle you want to use. 



 

The report display automatically updates to show the report using the selected autostyle. 
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Formatting a Graph Report 

You can also customize the format of a report in Graph mode.  Just like with Grid mode, the 
report automatically displays with a default graph format, but you can change various settings 
such as the graph type, titles, and the legend. 

 

 

The report display is updated as you apply each formattin
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To format a report in Graph mode: 
 

1. Switch the report to Graph 
mode. 

2. On the Format menu, click
Graph. 

NOTE:   This action displays 
the Format pane.  You can 
also display this pane by right-
clicking an object in the report 
that you want to format and 
clicking Advanced 
Formatting. 
 
OR 
 
On the Format menu, click 
Toolbar. 
 
OR  

 
On the View menu, point to 
Toolbars and click Format. 
NOTE:  These actions display 
the formatting toolbar, which 
you can also use to format 
graphs. 

3. On the Format pane or 
toolbar, format the graph as
desired. 

NOTE:  You can change the 
graph type and subtype, format 
and create titles, display data 
values, and modify a variety of 
other graph settings. 
 

g change. 
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